Missing text in Mixer contextual menu.

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!
Posts: 37
Joined: November 6, 2015 - 12:32
Missing text in Mixer contextual menu.

Hi, reporting a bug this time.
When I right click on the mixer window, the context menu that appears doesn't have text, well, it has a (R) but nothing more. If I click on it, it works (mute all channels, restore sound and reset).
I include a pic.
I am using Windows 8.1 64 bits.
I don't know if it could be related to having Japanese language as default language for text not compatible with unicode in the local system regional settings.
(Btw, I am Spanish and I don't know Japanese. I use that configuration because it is necessary to play some Japanese games.)

Attachments (Only registered users)
mixer_bug.png
Posts: 37
Joined: November 6, 2015 - 12:32
Re: Missing text in Mixer contextual menu.

I changed the regional settings back to Spanish and the problem continues. No text in Mixer contextual menu.

Posts: 1536
Joined: March 25, 2012 - 01:19
Re: Missing text in Mixer contextual menu.

Thanks for reporting it.

VMS should use the english version of untranslated strings, but it doesn't.
Now I've fixed it, will release the fix soon.

Meanwhile, since you're spanish and your language is one of the VMS "incomplete" languages, what about joining the translators group and help translating the missing strings?
Actually Spanish only misses 4 strings...

Translating VirtualMIDISynth is now easier and can be done completely on-line, no need to send translation files back and forth and no more issues with Unicode editors.
Once enabled, clicking on the "Translate software" menu item on the left of this website, then VirtualMIDISynth 1.x and finally on Spanish will let you start translating language items.
You can pause your work and restart it when you like.

At the bottom of translation page you'll find a link to download the translated file (even if incomplete) with the instructions on how to install it into your system.
This way you could test your translation by yourself.

If you like to help please let me know and I'll enable your account.
Then an updated version of VMS will be released with full Spanish translation.

Posts: 37
Joined: November 6, 2015 - 12:32
Re: Missing text in Mixer contextual menu.

Alright, I'll try to help with the localisation to Spanish.

Posts: 1536
Joined: March 25, 2012 - 01:19
Re: Missing text in Mixer contextual menu.

Great, welcome aboard ;)
Now you can click on Translate (left menu of this website), then VirtualMIDISynth 1.x and finally Spanish.

The system will automatically alert me about your translation progress...

PS: if you still cannot access the translation system (maybe because you have checked the "Remember me" option at last logon) please logoff and logon again.

Posts: 37
Joined: November 6, 2015 - 12:32
Re: Missing text in Mixer contextual menu.

Done, there were only 4 short sentences, but I have become aware of the many ways of translating a single word.
The contextual menu in Spanish looks OK now. I couldn't check  if the next string works well (meaning if it is too long) because I don't know where that text is located.

Key: cfg.key.8

Ori: reset mixer state

Trn: reinicializar estado del mezclador

Btw, in the original Spanish translation there is a textchain too long, so much that in the options is not possible to see the number 127.

Key: cfg.opt.reverb

Ori: &Reverb max level (0–127)

Trn: Valor máximo de &reverberación (0–127)

Valor máximo de reverberación is the more correct way of translating that but it is too long. Would it be okay to translate it just as Reverberación máxima?

 

Attachments (Only registered users)
reverberación.png
Posts: 1536
Joined: March 25, 2012 - 01:19
Re: Missing text in Mixer contextual menu.

Ok for the shortest one, I've added it.