Error -6 while opening MIDI Stream

Please let our ADS show!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).
Please:

  • disable your AdBlocker by adding CoolSoft website to whitelist
  • give the proper cookie consent
  • enable JavaScript for this website

This seconds wait is to let you update your browser configuration...

Ok, I've done the required changes... now show me your content!
!!! Please enable JavaScript !!!
Posts: 4
Joined: December 17, 2015 - 18:17
Error -6 while opening MIDI Stream

HI @ all,

I installed VMS 2.0 alpha24. First time when I start SONAR X, all is o.k.

Closing SONAR and starting SONAR again "Error -6 while opening MIDI Stream" popups.

(uninstall,install new, rename VirtualMIDISynth.conf, checking registry - nothing helped) 

How can I solve this problem?

Please help.

 

Win7 64bit

i7-5930K CPU

Realtek High Definition Audio (internal Soundcard)

Attachments (Only registered users)
VirtualMIDISynth - Copy.txt
Posts: 1683
Joined: March 25, 2012 - 01:19
Re: Error -6 while opening MIDI Stream

Error -6 of BASS libs is this:

"BASS_ERROR_FORMAT: The sample format is not supported by the device/drivers. If the stream is more than stereo or the BASS_SAMPLE_FLOAT flag is used, it could be that they are not supported."

It seems that the output format is not compatible with your audio device.

Try these steps:

  • change "Default output sample rate (Hz)" configuration option to 44100 or less
  • update soundcard drivers to the latest version available

If you can't solve it, please open "About" tab, click "Debug report..." button and post the created file here.

Posts: 4
Joined: December 17, 2015 - 18:17
Re: Error -6 while opening MIDI Stream

First, thanks for answering.

In the hope all would be better, I tried out your last version 2.0.0.beta in Win10 in combination with SONAR Prof.
Now I get Error -4 while opening MIDI Stream.

What does this error mean ? I can see 2 errors in the VirtualMidiSynth_debug_report.

How can I solve this problem?

Please help.

Attachments (Only registered users)
VirtualMIDISynth_debug_report.txt
Posts: 1683
Joined: March 25, 2012 - 01:19
Re: Error -6 while opening MIDI Stream

VMS 2.0 beta should show a textual description for its errors instead of the numeric code.
Error 4 is BASS_ERROR_BUFLOST, which is a nonsense in that context...

Don't care to errors in the debug reports, they are ok on Win10 because MidiMapper is missing.

Beta 3 will be released in a while, wait for it then try it again.
If you still have the error, please take a screenshot of it and attach to your next post.
Meanwhile, double check that your soundcard drivers are up to date.

NOTE: from now on please post VMS2-Beta errors in the dedicated thread, not here. This forum is dedicated to VMS1.