Windows 10...Won't let me set VMS as my default player

Posts: 3
Joined: April 24, 2015 - 21:24
Windows 10...Won't let me set VMS as my default player

Hi there. Anyone else having problems with Windows 10 and VMS?

I'm probably blind as well as stupid, but I can't see any updates to make it work.

I have been using it, very successfully, with my Mozart music software.

Help me somebody...:-)

 

thedadda48

 

Posts: 89
Joined: March 8, 2014 - 22:29
Re: Windows 10...Won't let me set VMS as my default player

If you're talking about making VMS the default MIDI device on Windows, well, nope.

Windows 10 misses the MIDI-Mapper, like Windows 8 and Windows 8.1.

I'm a software and soundfont developer!!!
YouTube: https://www.youtube.com/channel/UCJeqODojIv4TdeHcBfHJRnA
Website: http://keppystudios.com/

Posts: 3
Joined: April 24, 2015 - 21:24
Re: Windows 10...Won't let me set VMS as my default player

Thank you, KaleidonKep99, for your input. Much appreciated.

Don't suppose you can suggest an alternative/fix for this please?

 

thedadda48

 

Posts: 1125
Joined: March 25, 2012 - 01:19
Re: Windows 10...Won't let me set VMS as my default player

Sadly there's no fix possible for this, AFAIK.
You need to update/change your MIDI software (I don't know Mozart) to a version/one that lets you choose the output device (like VanBasco).
Take a look here: http://coolsoft.altervista.org/en/blog/2013/03/what-happened-midi-mapper...

Posts: 10
Joined: February 12, 2015 - 13:18
Re: Windows 10...Won't let me set VMS as my default player

What about this registry key? It works!

Posts: 1125
Joined: March 25, 2012 - 01:19
Re: Windows 10...Won't let me set VMS as my default player
VGA wrote:

What about this registry key? It works!

Which one? Can't see it...

Posts: 10
Joined: February 12, 2015 - 13:18
Re: Windows 10...Won't let me set VMS as my default player

Heh, forgot to post the link :-D

http://pcaudiohelp.com/how-to-change-the-default-midi-device-in-vista-an...

Posts: 1125
Joined: March 25, 2012 - 01:19
Re: Windows 10...Won't let me set VMS as my default player

That key works in Vista/7, where the MIDI Mapper is still present but hidden (no GUI to configure it).

Starting from Windows 8 the MIDI Mapper has been removed, so that key doesn't work anymore (except for Windows Media Player).

warning

Warning, JavaScript is disabled!

JavaScript is not available, maybe because you disabled it globally into your browser settings or you are using an addon like NoScript.

We do not have any dangerous JavaScript running here.
Please enable JavaScript; if you're using NoScript this image will help you adding CoolSoft to your whitelist.

Thanks for your comprehension and enjoy CoolSoft.