rtpMIDI / VMS loaded by a service instead of a application

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!
Posts: 1
Joined: October 24, 2016 - 10:21
rtpMIDI / VMS loaded by a service instead of a application

I'm messing around with rtpMIDI to connect sequencer software on a Win XP VM to VMS on the (Win 7) host machine.  Although it all ties together well enough to get sound out of VMS, there is no way to get at the UI. The tray icon does not appear, and although I can load the VirtualMIDIsynth executable, it merely starts a new instance.

rtpMIDIService, a Windows service, seems to do the actual calling of VMS, and VirtualMIDIsynth.exe loads up under the SYSTEM user.  I tried changing the logon of rtpMIDIservice to my local username, and then saw VMS load with that username, but it made no difference. 

Any way around this?

My OS is Windows 7 SP1, x64.

Posts: 1512
Joined: March 25, 2012 - 01:19
Re: rtpMIDI / VMS loaded by a service instead of a application

AFAIK there's no way for a windows service (running in session 0) to access the desktop.
That's because the session 0 is "hidden" from user.

I suppose that rtpMIDI automatically starts with Windows, so it also loads VirtualMIDISynth.exe.

The first thing that comes to my mind is:

  • disable rtpMIDI service autostart
  • stop rtpMIDI service
  • start VirtualMIDISynth.exe manually (as user)
  • start rtpMIDI service (as SYSTEM)

VMS driver component starts an instance of VirtualMIDISynth.exe only if no running instance is found.
Since it runs as SYSTEM it can access all processes, including the current user ones, so the running process should be found.

Could you please check it out? (should be easier for you, having all the required components ready...)

PS: if it works, then this procedure can be easily automated with a .bat file.