Avid Sibelius can't see the MIDI device

Anonymous user
Avid Sibelius can't see the MIDI device


I installed your VirtualMidiSynth software and it is superb.
The only problem I have is that I cannot select it inside Avid's Sibelius.
VirtualMidiSynth appears grayed out in the list of available devices.

Any ideas? :)

Thanks again for a great piece of software.

Posts: 1430
Joined: 25 Mar 2012 - 01:19
Beta version

Other users experienced a similar issue with other DAWs.
I suppose this is a "limitation" of client software (Sibelius), which requires the device to be a SYNTH and not a generic MIDI Output port.
I saw this very same issue on Reaver.

New version will change the way VirtualMIDISynth show itself into the system, from the actual MOD_MIDIPORT to MOD_SWSYNTH, like MS bundled synth does.
I've sent you the 1.5.0-beta1 version, please let me know if it solves the issue.

If not, please let me know if Sibelius has a demo/trial version to test.

Anonymous user
Sibelius playback

Thank you for the fast response, wow!
Unfortunately I installed the new version you sent me and it made no difference. The VirtualMIDISynth still shows up grayed out in the list.

Apparently there is a demo version of Sibelius offered by AVID:

Let me know how else I can help.

Thank you very much once more!

Posts: 1430
Joined: 25 Mar 2012 - 01:19
Will download the trial

I found the Sibelius trial, version 7.1.2.
I'm downloading it right now (it's a huge download of about 512MB!).

I'll take a look at it ASAP.

Posts: 1430
Joined: 25 Mar 2012 - 01:19
Fixed, but VMS is not the culprit

After a lot of work, nothing interesting came out of my testing.

The I tried to find if someone have the same issue with other MIDI devices and I found this post on Sibelius forum:

Since the link could die, I'll copy here an excerpt of the original answer from Sibeluis user Robin Walker:

It sounds as if this is a "Configurations" issue in "Playback Devices".
The Playback Configurations that ship with Sibelius are read-only and cannot be changed (for instance, by the addition of your MIDI device).

To use a MIDI device as output, you need to CREATE a new "Configuration".
Then, with that new Configuration selected, your MIDI output device will no longer be greyed out in the left-hand column, and you can move it over into the right-hand column.

Can't find a reason for this choice, but that's another story.
Tested on trial version and it worked perfectly, please confirm if it works for you too.

PS: VirtualMIDISynth is innocent ;)

Anonymous user
Thank you


Thank you very much again. I swear I have been looking for a solution on the internet forums for a while now and never found the post you found. It WORKS!

I have to apologize since this falls on me.

And I am glad you posted the conversation so that other users are aware of the potential pitfall.

Thank you again, I will make sure to spread the word.

Posts: 2
Joined: 5 Lug 2017 - 04:38
Re: Thank you

Could you please explain to me the "new configuration" means? Is that the setting on the sibelius software or windows playback device setup?

Posts: 1430
Joined: 25 Mar 2012 - 01:19
Re: Thank you

Sorry, I can't remember how I did it... this thread is 5 years old (2012!)...


Warning, JavaScript is disabled!

JavaScript is not available, maybe because you disabled it globally into your browser settings or you are using an addon like NoScript.

We do not have any dangerous JavaScript running here.
Please enable JavaScript; if you're using NoScript this image will help you adding CoolSoft to your whitelist.

Thanks for your comprehension and enjoy CoolSoft.