Component already exists

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!
Anonymous user
Component already exists

Hi, tx for a really great tool !!!

Yesterday I created a custom page, and today I would to reopen from the recent, and it gaved an error, that the component already exist. 

Posts: 1536
Joined: March 25, 2012 - 01:19
Can't reproduce it

This error is due to duplicate control names and will be fixed in next version.

Duplicate control names can be generated during Copy/Paste operations.

Meanwhile, open the .nsddef file with a text editor (better if it has XML syntax highlighting, like Notepad++), look for the "Name" property of each item and remove duplicates.

Anonymous user
File that reproduces issue

Ran into this problem as well on a file that was created with a version 0.9.6. The nsddef file is below:

 version="1.0" encoding="Unicode"?>

 Font="Microsoft Sans Serif, 8.25pt" Title="text" Subtitle="text" ForeColor="ControlText" BackColor="Control">
  >Call Initialize>
   Name="Label8" Location="44, 134" Size="390, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label7" Location="44, 100" Size="390, 28" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label6" Location="44, 80" Size="390, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label5" Location="44, 60" Size="390, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label4" Location="27, 100" Size="14, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label3" Location="27, 80" Size="14, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label2" Location="27, 60" Size="14, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label1" Location="14, 24" Size="430, 28" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="FileMessage" Location="14, 2" Size="420, 14" Text="" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="GroupBox1" Location="14, 167" Size="424, 55" Text="text" Font="Microsoft Sans Serif, 8.25pt">
     Name="Location" Location="17, 22" Size="310, 20" Text="" Font="Microsoft Sans Serif, 8.25pt" ForeColor="WindowText" BackColor="Window" onChange="OnLocation" />
     Name="Browse" Location="338, 20" Size="75, 25" Text="Browse..." Font="Microsoft Sans Serif, 8.25pt" onClick="OnBrowse" />
  >
>
Anonymous user
Ran into this problem with

Ran into this problem with v0.9.8 on a file that was created with a version 0.9.6. The nsddef file is below (the text fields were replaced with dummy values):

 version="1.0" encoding="Unicode"?>

 Font="Microsoft Sans Serif, 8.25pt" Title="text" Subtitle="text" ForeColor="ControlText" BackColor="Control">
  >Call Initialize>
   Name="Label8" Location="44, 134" Size="390, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label7" Location="44, 100" Size="390, 28" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label6" Location="44, 80" Size="390, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label5" Location="44, 60" Size="390, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label4" Location="27, 100" Size="14, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label3" Location="27, 80" Size="14, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label2" Location="27, 60" Size="14, 14" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="Label1" Location="14, 24" Size="430, 28" Text="text" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="FileMessage" Location="14, 2" Size="420, 14" Text="" Font="Microsoft Sans Serif, 8.25pt" ForeColor="ControlText" BackColor="Control" />
   Name="GroupBox1" Location="14, 167" Size="424, 55" Text="text" Font="Microsoft Sans Serif, 8.25pt">
     Name="Location" Location="17, 22" Size="310, 20" Text="" Font="Microsoft Sans Serif, 8.25pt" ForeColor="WindowText" BackColor="Window" onChange="OnLocation" />
     Name="Browse" Location="338, 20" Size="75, 25" Text="&Browse..." Font="Microsoft Sans Serif, 8.25pt" onClick="OnBrowse" />
  >
>

 

Posts: 1536
Joined: March 25, 2012 - 01:19
Update available

I just released version 0.9.9, it should fix the issue you reported.
Please let me know...