BASS_ERROR_UNKNOWN on Windows 10 build 1903

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!
Posts: 4
Joined: October 25, 2019 - 00:49
BASS_ERROR_UNKNOWN on Windows 10 build 1903

So VirtualMidiSynth was working a few days ago.

Then a very quick windows OS update occurred.

VirtualMidiSynth stopped working somewhere around that time.

Gives me the BASS_ERROR_UNKNOWN error popup.

I uninstalled VMS. Rebooted.  Reinstalled.
Same error.
This also happens with 2.8.0 beta 3.

Posts: 1544
Joined: March 25, 2012 - 01:19
Re: BASS_ERROR_UNKNOWN on Windows 10 build 1903

I'm on the same Windows version, updated at today, but don't have that issue.

You could try to:

  • Update your soundcard drivers, both using Windows Update and your PC vendor website
  • Try to uninstall that last "quick windows OS update" and check if everything get back working properly.
    You can find the list of installed updates (ordered by installation date) in your control panel or searching for "windows update history".
    Please take note of the number of the update you're going to remove...
Posts: 4
Joined: October 25, 2019 - 00:49
Re: BASS_ERROR_UNKNOWN on Windows 10 build 1903

As soon as my other computer updated to Windows 10 v1909, VirtualMidiSynth immediately stopped working as well, with the BASS_ERROR_UNKNOWN error.
I just installed 2.8.0 (was using 2.7.3 before), and it has the same issue.

Posts: 4
Joined: October 25, 2019 - 00:49
Re: BASS_ERROR_UNKNOWN on Windows 10 build 1903

For a bit more info:
My work machine has onboard audio (Realtek).
My PC at home has an Auzentech X-Fi Prelude.

Posts: 4
Joined: October 25, 2019 - 00:49
Re: BASS_ERROR_UNKNOWN on Windows 10 build 1903

Oh right --> I have installed the latest audio drivers on each machine.