Issues with Encoder Options

Please let our ADS show!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).
Please:

  • disable your AdBlocker by adding CoolSoft website to whitelist
  • give the proper cookie consent
  • enable JavaScript for this website

This seconds wait is to let you update your browser configuration...

Ok, I've done the required changes... now show me your content!
!!! Please enable JavaScript !!!
Posts: 3
Joined: July 11, 2020 - 18:45
Issues with Encoder Options

I'm trying to convert my MIDIs to 16-bit 44.1 kHz instead of 48 kHz, and I have no idea how to do so. I don't know of any encoder options for WAV conversion to change the sampling rate, and when trying to use FLAC, putting "--bps=16 --sample-rate=44100" in the "Additional encoder options" box makes the conversion fail instantly. The conversion works when there's no options, but the files are all 24-bit 48 kHz. What am I doing wrong here? Thanks.

Posts: 3
Joined: July 11, 2020 - 18:45
Re: Issues with Encoder Options

I figured it out: All I had to do was go to Configuration > Options > Default output sample rate (Hz) and change it from "48000" to "44100". I just have one question remaining: will setting the additional output buffer back to a value greater than 0 (such as 250 ms) help with making the tempo more consistent and accurate in MIDI files rendered to WAV? Or does that setting only apply to real-time playback? Thanks.

Posts: 3
Joined: July 11, 2020 - 18:45
Re: Issues with Encoder Options
Plut0nio wrote:

I just have one question remaining: will setting the additional output buffer back to a value greater than 0 (such as 250 ms) help with making the tempo more consistent and accurate in MIDI files rendered to WAV? Or does that setting only apply to real-time playback? Thanks.

I tested this out with a buffer of 500 ms and the tempo didn't seem any more consistent/accurate. In fact, the resulting file was the exact same (the checksums verified this).

Posts: 1782
Joined: March 25, 2012 - 01:19
Re: Issues with Encoder Options

Sorry for the late reply.

Plut0nio wrote:
does that setting only apply to real-time playback?
The buffering only affects realtime playing, as you suspected.
The setting is not used at all by MIDIConverter.

Plut0nio wrote:
I figured it out: All I had to do was go to Configuration > Options > Default output sample rate (Hz) and change it from "48000" to "44100"
Good catch ;)
That settings applies to the whole BASS audio configuration of VirtualMIDISynth, so it affects WAV rendering too.
WAV is a simple "redirection" of the analog output stream to a file.