VirtualMIDISynth 2.8.0 - Beta

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!

Pages

Posts: 77
Joined: October 14, 2016 - 03:20
Re: VirtualMIDISynth 2.8.0 - Beta

Ah yes, I just remebered one bug that's has probably been in since 2.0 but that I always forget about

It's that the current selected soundfonts on the soundfont chain apply (as if you pressed the apply button) by themselves when the midi player plays a new midi/replays a midi even if you didn't press apply, maybe related to when VMS clients disappear/appear

Talking about the apply button, it would be nice thing to change the gray "apply" button for "update" or "reload" or even as simple as to just leave "apply" always clickable when the soundfonts selected on the chain are unchanged, basically it would reload the soundfonts, this would be really useful for testing soundfonts that are being edited really quickly, currently it needs to have a change on the selected chain for vms to let you "apply", so when testing soundfonts I have to disable the soundfont, press apply, get error mesage that there is no soundfont selected on the chain, then enable and apply, changing all that for 1 click would be great and shouldn't be too hard to implement(?) ;)

Cheers

Posts: 1536
Joined: March 25, 2012 - 01:19
Re: VirtualMIDISynth 2.8.0 - Beta
Anonimo_LLopi wrote:
Anyways, are you planning to implement more new features on 2.8.x? ;D

No, there should not be any other new feature to be added on 2.8.

Yes, the TODO list still contains a lot of things to do, as you can see, but I think that 2.8 list of changes is enough for a release.
I don't want to put too many irons in the fire ;)

Posts: 1536
Joined: March 25, 2012 - 01:19
Re: VirtualMIDISynth 2.8.0 - Beta
Anonimo_LLopi wrote:

Ah yes, I just remebered one bug that's has probably been in since 2.0 but that I always forget about.

It's that the current selected soundfonts on the soundfont chain apply (as if you pressed the apply button) by themselves when the midi player plays a new midi/replays a midi even if you didn't press apply, maybe related to when VMS clients disappear/appear.

That's really a good catch, thanks for reporting it ;)
The soundfont list editor was editing the in-memory SF list instead of a temporary copy to be saved on Apply/Ok press.
Fixed in Beta3.

Anonimo_LLopi wrote:

Talking about the apply button, it would be nice thing to change the gray "apply" button for "update" or "reload" or even as simple as to just leave "apply" always clickable when the soundfonts selected on the chain are unchanged, basically it would reload the soundfonts, this would be really useful for testing soundfonts that are being edited really quickly, currently it needs to have a change on the selected chain for vms to let you "apply", so when testing soundfonts I have to disable the soundfont, press apply, get error mesage that there is no soundfont selected on the chain, then enable and apply, changing all that for 1 click would be great and shouldn't be too hard to implement(?) ;)

Apply button status is shared between all of the configurator tabs so, yes, it could be a mess to leave it "always on".

As a workaround you could use this shorter sequence to re-enable Apply button (you need at least 2 soundfonts in your list): move SF down, move SF back up, press Apply.
It should be easier than Disable --> Apply --> Enable --> Apply because Down/Up buttons are nearer each other, then you need a single click on Apply...

Pages