[Fix]Experimental fix for "Driver not installed correctly" issue after 1909 update

Please let our ADS show!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).
Please:

  • disable your AdBlocker by adding CoolSoft website to whitelist
  • give the proper cookie consent
  • enable JavaScript for this website

This seconds wait is to let you update your browser configuration...

Ok, I've done the required changes... now show me your content!
!!! Please enable JavaScript !!!
Posts: 3
Joined: 26 Giu 2020 - 03:01
[Fix]Experimental fix for "Driver not installed correctly" issue after 1909 update

[WARNING] If you going to try this fix at home, please backup the DLLs, I take no responsibility if your computer audio stop working!

I recently reinstalled windows 10 due to windows updates introduced bugs over two years and finally made the system unusable. after a fresh reinstall, and downloaded all software I use, I noticed this "Driver not installed correctly" on every startup.

The adventure to fix the issue has begun. first, I did some search and found out I'm not the only one who had this problem, and there isn't a permanent solution for it, yet... Until now!!! According to previous adventurers, this issue is caused by windows continuously rest a registry key(two if on amd64 system), they are:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\midi1

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32\midi1

so, I tried to create a startup task that reset the registry to the correct value, and then launch VirtualMidiSynth.exe, but it doesn't work every time. I even went on an extreme approach, run a repeating task that reset it every minute for a duration of time after startup, still, not every time.

task scheduler

Since this didn't work, I start to "think differently"(not like what Apple did, I HATE Apple), if I can find out what modified the registry key, then I should be able to stop it from doing it, right? So I set up an event auditing on the effected registry key and restarted the computer, in the event viewer, I found a record that happened during the startup time and the PID of the source points to a system process called "svchost.exe", which corresponds to "Windows Audio Endpoint Builder" Service.

Now I found the suspect, it's time to do a test to verify that my suspicion is correct. I went to the interweb and searched for DLL called "AudioEndpointBuilder.dll". On https://www.dllme.com/, I found these two DLLs from the same 2017 windows release and downloaded them.

I took the ownership of "AudioEndpointBuilder.dll" and "AudioHandlers.dll" located under "C:/Windows/System32/" directory, and replaced them with the one I downloaded online. My theory is since this software worked flawlessly back when I first installed windows 10, an older service DLL should not have this bug. After I replaced those files, I disabled the startup tasks I created and restarted my computer.

Jackpot!!! the registry keys are still intact after a reboot, and I reboot a few more times to make sure this is working.

Feel free to try this fix and let me know if this worked for you guys. This only fixes the problem caused by the 1909 update, no guaranteed success for other causes. If it worked for more people, I might consider making a video on exactly how to do this to help other people who are not that experienced with computer things.

DLL files link: https://mega.nz/file/6h0BTa7C#hLPyCyuj0W09yw2iTcpkfvcS_Se7WHvXgiI-EDFVxvs

I used to be an adventurer like you, then I took an arrow in the knee...

Posts: 25
Joined: 27 Maggio 2015 - 16:09
Re: [Fix]Experimental fix for "Driver not installed correctly" issue after 1909 update

Hi ... I have read and followed the steps to fix the annoying bugs start reinstalling the drivers .... it is ..........

amazing worked !!!!!!!!!!!!!!!      ...all ok to every reboot the pc ... fantastic ..she's a genius ....compliments and thank you very much ....

Posts: 1683
Joined: 25 Mar 2012 - 01:19
Re: [Fix]Experimental fix for "Driver not installed correctly" issue after 1909 update

@Mikeyzy: I appreciate your attempt to fix this issue, but I think this is really really dangerous.
Even if it fixes the bug, mixing DLLs (in this case Windows Services) between Windows versions is a very bad idea... it's a "recipe" for a disaster.

Windows Audio Endpoint Builder have a "new feature" (in MS words) that repopulates the legacy Drivers32 registry key at each reboot (and also during system uptime).

Well, to our eyes it could seem like a new bug, so rolling back to previous one fixes it.
But think about how many other changes the new service contains, and they're expected to be there by the rest of the OS.
Rolling it back they're gone and this could lead to unpredictable results in the future.

That said, now the good news ;)
I've just released a beta with a fix for this "bug", you can find it in the dedicated thread.
Please check it out and report your findings there.

If anyone replaced DLLs as reported here, please get back to the original ones and test the beta version.

Posts: 3
Joined: 26 Giu 2020 - 03:01
Re: [Fix]Experimental fix for "Driver not installed correctly" issue after 1909 update

thanks for the effort, I'll try the new version and see if it fix it.

it's been working until now (possibly due to another system auto-update happened), but it's sound bank related this time, manually reload the settings fixed it. so far I can say it didn't cause any noticeable problem.

Personally i don't really care if windows add new features or not, I just want my thing to work, and if rollback old dlls work, for me it's a valid solution :P

As I stated above, do it at your own risk, so this is only for advanced users that know what they are potentially opening system vulnerability by roll back system service.

I simply wish I could disable update entirely and not have to deal with this kind of problem, but it isn't possible at this point

I used to be an adventurer like you, then I took an arrow in the knee...

Posts: 3
Joined: 26 Giu 2020 - 03:01
Re: [Fix]Experimental fix for "Driver not installed correctly" issue after 1909 update

I tried the latest version, with the up to date windows services, which gave me the same result as before, so I'll stick with this until microsoft decided to fix their broken OS.

I used to be an adventurer like you, then I took an arrow in the knee...