Not working with MPC-HC

Please let our ADS show!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

  • disable your AdBlocker by adding CoolSoft website to whitelist
  • give the proper cookie consent
  • enable JavaScript for this website

This seconds wait is to let you update your browser configuration...

Ok, I've done the required changes... now show me your content!
!!! Please enable JavaScript !!!
Posts: 3
Joined: 17 Ago 2020 - 23:37
Not working with MPC-HC

I'm getting an error when trying to play MIDI files in Media Player Classic Home Cinema, on a fresh installation of the K-Lite Codec Pack, on Windows 10 Version 2004, Build 19041.508. (Had to reformat/reinstall Windows yesterday due to unrelated issues.)
I installed MIDIMapper 2.1.0 and VirtualMIDISynth 2.10.1 first, then K-Lite Codec Pack 15.7.5 (Full).

After getting the error, I tried reinstalling both MIDIMapper and VMS. No luck. Same for disabling the Microsoft GS Wavetable Synth in Device Manager.

Note that Windows Media Player works fine.

Error text (same as in screenshot):

File Source (Async.)::Output
MIDI Parser::Out
Media Type 0:
majortype: MEDIATYPE_Midi {7364696D-0000-0010-8000-00AA00389B71}
subtype: TIME_FORMAT_NONE {00000000-0000-0000-0000-000000000000}
formattype: TIME_FORMAT_NONE {00000000-0000-0000-0000-000000000000}
bFixedSizeSamples: 0
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 32
0000: e0 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 à...............
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
Attachments (Only registered users)
Posts: 1822
Joined: 25 Mar 2012 - 01:19
Re: Not working with MPC-HC

I've had a similar issue some time ago and... I was never able to fix it, sorry :(
It fixed by itself after a Windows Version upgrade (1709-->1804), then got back again on 1903.

On my side only x86 version of MPC-HC had the bug, while x64 version worked ok.
So, as a workaround, you could try to switch to x64 version of ot (or to x86 if you're already using x64).

Posts: 3
Joined: 17 Ago 2020 - 23:37
Re: Not working with MPC-HC

Well, that sucks. Thanks anyway. Maybe it'll re-fix itself with 20H2.

Posts: 6
Joined: 20 Ago 2017 - 18:22
Re: Not working with MPC-HC

in case you still use the original, old 1.7.13 version of MPC-HC, then try the maintenance version.

Posts: 3
Joined: 17 Ago 2020 - 23:37
Re: Not working with MPC-HC

Well... it works now. And I'm on Version 2009.

And I have no idea whether that fixed things or not. Because Windows is stupid.

Posts: 19
Joined: 16 Giu 2016 - 19:07
Re: Not working with MPC-HC

I had exactly the same issue on Win10 v2009 a few days ago (MPC-HC + K-Lite). The problem was not specific to MPC, it occurred with WMP as well.

Anyway, it disappeared by itself after a reboot... /strange