High DPI breaks the interface

Please let our ADS show!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).
Please:

  • disable your AdBlocker by adding CoolSoft website to whitelist
  • give the proper cookie consent
  • enable JavaScript for this website

This seconds wait is to let you update your browser configuration...

Ok, I've done the required changes... now show me your content!
!!! Please enable JavaScript !!!

Pagine

Posts: 1733
Joined: 25 Mar 2012 - 01:19
Re: High DPI breaks the interface

@Mintmag: nevermind, I got it and I'm able to reproduce it.

I've took a bad decision when I decided to declare VMS as dpi-aware in ints app manifest.
I've added to let VMS retrieve the size of the additional transparent border added to dialogs by the OS starting from Windows 8.
Whithout this info, snapping windows to desktop borders was wrong: because of the additional transparent border, the windows snapped only near-to desktop borders, but not really "attached" to them.

Sadly the hiDpi functions require an all-or-nothing decision, so you can't mix non-hiDpi and hiDpi function, like I did 🙄.

To make a long story short, as a workaround please disable the Windows snap option in VMS configuration --> Options tab --> Appearance section.

I'm actually working on a full hiDpi-aware version and I'll post a beta soon 😉

Posts: 8
Joined: 1 Feb 2021 - 14:42
Re: High DPI breaks the interface
coolsoft wrote:

@Mintmag: nevermind, I got it and I'm able to reproduce it.

I've took a bad decision when I decided to declare VMS as dpi-aware in ints app manifest.
I've added to let VMS retrieve the size of the additional transparent border added to dialogs by the OS starting from Windows 8.
Whithout this info, snapping windows to desktop borders was wrong: because of the additional transparent border, the windows snapped only near-to desktop borders, but not really "attached" to them.

Sadly the hiDpi functions require an all-or-nothing decision, so you can't mix non-hiDpi and hiDpi function, like I did 🙄.

To make a long story short, as a workaround please disable the Windows snap option in VMS configuration --> Options tab --> Appearance section.

I'm actually working on a full hiDpi-aware version and I'll post a beta soon 😉

Sorry for the late reply, glad to hear that you're working on patch. Please let me know once the Beta is out and I'll go download it.

Pagine