Dosbox - soundfonts make no difference

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!
Posts: 3
Joined: July 22, 2015 - 07:23
Dosbox - soundfonts make no difference

Howdy, thanks for putting so much effort into this project.

My issue is that I've tried VMS with two games (Doom on Steam and SimCity2000 on Origin) both of which use Dosbox for compatibility purposes. In both cases, no matter which of the three soundfonts I use (I've downloaded ChoriumRevA, FluidR3_GM and SGM-V2.01), and no matter the combination of options I pick on the MIDI Mapper tab, the music in these two games sounds identical. I think judging from Youtubes of the Doom soundtrack it's using the AdLib soundtrack which might be the default on my machine (Windows 7)?

In both cases I've tried setting the MIDI options in the Dosbox configuration files to those I've seen widely reported as working (mpu401=intelligent, mididevice=win32, midiconfig=0) which doesn't seem to make any difference.

The music even sounds the same with no soundfont selected in VMS, which returns an error when Dosbox starts up!

http://i.imgur.com/ytBwpGN.png

 

e: forgot to mention this was with version 1.3 and since I posted I uninstalled and tried alpha 16 of version 2 which also doesn't seem to change the music

Posts: 1535
Joined: March 25, 2012 - 01:19
Re: Dosbox - soundfonts make no difference

What you report is really strange because VMS shows that warning message when someone uses it (as DosBox seems to do) BUT you haven't configured a soundfont.

Again if you haven't configured a soundfont you can't hear anything from VMS, so what you hear should come from another soundcard/emulation selected (but so why you see that message?).

Things to check:

  1. Open VirtualMIDISynth configurator alone (through the Start menu), without playing anything, and check that a soundfont is configured.
    If it's not, add one.
  2. Close and reopen configurator again to see if configuration has been saved.
  3. Start DosBox and check if the warning message still appears
  4. Start your game and, when you hear music, right-click on VirtualMIDISynth systray icon and select Show mixer to open MIDI Mixer.
    Check if you see MIDI activity sent to VirtualMIDISynth.

So first we need to remove that warning message, then check if VMS is the device really used by DosBox.
Please tell me which of the previous points fails/succedes.

Posts: 3
Joined: July 22, 2015 - 07:23
Re: Dosbox - soundfonts make no difference

I'm guessing the green icon indicates VMS thinks everything is working, but the lack of activity in the mixer means it's not?

 

Also when I previewd this post with the attachment uploaded it gave me this error message, I hope this works

 

  • Notice: Undefined index: filename in include() (line 20 of /membri/coolsoft/sites/all/modules/coolforum/template/coolforum-post-attachments.tpl.php).
  • Notice: Undefined index: filesize in include() (line 22 of /membri/coolsoft/sites/all/modules/coolforum/template/coolforum-post-attachments.tpl.php).
  • Notice: Undefined index: timestamp in include() (line 22 of /membri/coolsoft/sites/all/modules/coolforum/template/coolforum-post-attachments.tpl.php).
  • Warning: date_timezone_set() expects parameter 1 to be DateTime, boolean given in format_date() (line 2040 of /membri/coolsoft/includes/common.inc).
  • Warning: date_format() expects parameter 1 to be DateTime, boolean given in format_date() (line 2050 of /membri/coolsoft/includes/common.inc).
Attachments (Only registered users)
Untitled.png
Posts: 1535
Joined: March 25, 2012 - 01:19
Re: Dosbox - soundfonts make no difference

If device is initialized, MIDI Mixer channels show instrument name; from the screenshot you sent the device seems to be uninitialized.
Are you sure your game is configured to use VirtualMIDISynth? Does it have a sound configuration dialog?

I'm not an expert of DOS games, but I've attached a screenshot of how GZDOOM appears when configured to use VirtualMIDISynth #1 device.

I also have another DosBox ZIP (sent by an user to debug an issue some times ago) and this is how the MIDI section of its configuration file looks:

[midi]
mpu401=intelligent
mididevice=default
midiconfig=
mt32.reverse.stereo=off
mt32.verbose=off
mt32.thread=off
mt32.dac=auto
mt32.reverb.mode=auto
mt32.reverb.time=5
mt32.reverb.level=3
mt32.partials=32

PS: thanks for forum bug report, will have a look ASAP.

Attachments (Only registered users)
GZDOOM.jpg
Posts: 3
Joined: July 22, 2015 - 07:23
Re: Dosbox - soundfonts make no difference

There's no sound option menu in game, it's set up in the .conf files, and I'd have thought it was set up ok given the line in the Dosbox console saying "MIDI:win32 selected VirtualMIDISynth #1"

 

I tried replacing my midi section with those lines, and adding them after my version, and neither made any difference

This appears in the .conf files so I think I had the syntax ok as it stood

[midi]
# mpu401      -- Type of MPU-401 to emulate: none, uart or intelligent.
# device      -- Device that will receive the MIDI data from MPU-401.
#                This can be default,alsa,oss,win32,coreaudio,none.
# config      -- Special configuration options for the device. In Windows put
#                the id of the device you want to use. See README for details.

Posts: 1535
Joined: March 25, 2012 - 01:19
Re: Dosbox - soundfonts make no difference

What if you play a MIDI with Windows Media Player or VanBasco?
Please check if VirtualMIDISynth is set as default player within its configurator...