Setting Bank = -1 results in no playback

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!
Posts: 1
Joined: September 29, 2017 - 06:48
Setting Bank = -1 results in no playback

I want to preface my question by saying that I am by no means a MIDI or SoundFont expert.
I'm simply an enduser who wants a better MIDI listening experience. :)

I'm currently composing a track in SynthFont, with two of the tracks relying on other banks (bank = 8) than the preset bank = 0.
When I go into the "Edit soundfont properties" in the VirtualMIDISynth controller, I set Bank = -1 to load all banks, but this results in no playback.
Setting Bank = 0 after I've opened the MIDI file in Windows Media Player gets the track to play and load the correct banks and presets.

Am I doing something wrong, or is it a minor bug in VirtualMIDISynth?
I'd like to be able to just open a MIDI file and have the right banks/presets be loaded instead of doing the three-step process described above.

Thank you in advance for any responses.

Posts: 1536
Joined: March 25, 2012 - 01:19
Re: Setting Bank = -1 results in no playback

Well, believe it or not, I'm not a MIDI/SoundFont expert too :D
Most of the VirtualMIDISynth MIDI/SoundFont/Synth tasks are done by BASS libraries (http://un4seen.com).

Are you sure your MIDI player is sending the right bank select messages?
When you preload a single bank of a soundfont (bank settting = 0), that bank is selected and used as default one even if no specific bank is selected.
If you preload all soundfonts (bank settting = -1) then - I suppose - you should select a specific bank using Bank Select control change message (https://en.wikipedia.org/wiki/General_MIDI_Level_2#Supported_Control_Cha...).