VirtualMIDISynth slower in Windows 10

It seems you're using an AdBlocker or JavaScript is disabled!

This sites offers only FREE software and it's supported by a few advertisement boxes (no intrusive popups).

This 10 seconds wait is to let you update your AdBlocker whitelist...

Got it, show me the content...
Please enable JavaScript!
Posts: 5
Joined: December 26, 2019 - 08:43
VirtualMIDISynth slower in Windows 10

Hello,

I just installed VirtualMIDISynth on a new Windows 10. The lag is quite higher than on my old computer with Windows 7.

I set latency to 1 ms. Also, Sampling frequency to 22050.

Probably the issue is with the new equipment (a Surface + win 10) and not due to Coolsoft, but any other parameter setting to improve latency would be appreciated.

Thanks!

Posts: 1584
Joined: March 25, 2012 - 01:19
Re: VirtualMIDISynth slower in Windows 10

I've noticed no latency increase on my Win10 system than I had in the past on my previous (and much slower) Win7 laptop.
I've also upgraded another laptop from Win7 to Win10 (--> same hardware, just upgraded the OS) with no noticeable latency worsening...

Please check the usual things:

  • update drivers to the latest version (all of them, not only the sound card ones)
  • disable any "audio effect" provided by the soundcard driver (echo, reverb, equalization, ...)
  • double check if your MIDI Player is set to 0 latency and send MIDI data straight to VirtualMIDISynth